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1. Document History 
 

Version Date  

1.0 19-May-11 Initial document creation and first release 
 

2. What you can do with BrainWave™  
 

BrainWave™ (BW) is a software tool developed to acquire, store and analyze data provided by the 

high-density MEA system Biocam4096™. Raw data traces, simultaneously recorded from 4096 

electrodes of the NeuroChip™ and sampled at about 8KHz/channel, are stored in .brw files. These 

files can successively be loaded by BW to visualize the recorded activity off-line. In addition, BW 

provides spike detection algorithm and first order analysis statistic such as Mean Firing Rate (MFR) 

and Inter Spike Interval (ISI) to provide to the user global parameters of the network activity. The 

analysis results are saved in a different file (.bxr) which is linked to the raw data allowing to 

conveniently move from the results to the raw data and vice versa. 

3. Minimum platform requirements 
 

BrainWave™ works under Windows XP®, Windows Vista® and Windows 7® at 32 or 64-bit 

configuration. The .net 4.0 Framework installation is a prerequisite. The minimum hardware 

requirements are: 

 processor Intel 1.4GHz (or equivalent) 

 at least 1 Gigabyte of RAM (2 Gigabytes suggested) 

 minimum of 1 Gigabytes disk space available 

4. How to install BrainWave™  

 

For software installation launch the setup.exe and follow the instructions. 

Important: For the software to work properly, set the “regional option” tab to “English”, in the 

“regional and language option” window in control panel! 

5. First step 
 

5.1. Record a file 

Initialization/Start procedure 

1. Turn off the BioCAM.  

2. Close BrainWave.  
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3. Plug in the test-chip and close the connector.  

4. Turn on the BioCAM.  

5. Launch BrainWave. 

 

 

Click on the first icon from the left in the menu (1) to open the recording window.  The right LED 

should turn on. That means the BioCAM sends data to the Computer. 

 

System test 

1. Make sure that the Amplitude Bar in the Graphs Managing Panel (2) is on full scale (you 

can double-click on the bar between the two limits or just move each limit to its absolute 

position). 

[Typical setting: -0.7 - +0.7] 

2. Set Image Displaying (3) to “Variance”. 

3. Push the Play-Button in the Controls Panel (4) to start the acquisition.  

 

Then, you should see the image of the array in blue (set colorbar (5) appropriately [typical setting: 

right click of the mouse with the pointer on the colorbar, set Exp scale]). Low noise should be 

visible on the image. Gain (6) shall be set between 1 and 5 [typical setting: 3.5]. Frame Rate must 
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not be changed for the full array recording. Click on a single Pixel on the 2D-Array to display a 

single channel‟s waveform. The interval of the crosshair (7) can be set with the number in the 

Frame Field (8) [typical setting: 250 frames (~ 30msec), above the raw interval is set to 250-

500msec]. 

 

Troubleshooting 

If you see single columns displayed in uniform colors (i.e. with no noise contribution) and different 

from the remaining array, contacts might be weak. Close and open the connector a few times and 

move the chip slightly back and forth when the connector is closed. If this does not help, try to 

clean the connectors on the chip with Ethanol or detergent. If, again, this does not help, the chip is 

probably partially broken. These columns will not work anymore, however the remaining columns 

can still work. Usually, columns that do not work (either because they are broken or because there 

might be a connector issue) appear in multiples of 4 and at a distance of 16, since four columns are 

multiplexed on one output channel and there are 16 output channels. If you open the connection 

between the Chip and the BioCAM you will have to re-start the program. 

If you still have problem, try to clean gently the gold pads on the chip with a Q-tip or similar soaked 

with ethanol. 

Once these initial tests to check for connectivity are terminated, you can proceed to recording. 

 

Recording 

1. Set Duration (9). 

2. Choose a file location and file name in the File Path of the Experiment Info Panel (10) 

[typical setting: select the hard drive with RAID0 configuration]. 

3. Press the Record Button (11). 

4. You can select different pixels to display the waveforms of channels on-line, to visualize 

more channels at the same time, drag and drop on a selected area or shift + click on different 

channels. The maximum numbers of channels that can be visualized are generally set to 12. 

Select from the main menu Edit->Preferences, a “Preference Form” panel will appear, in 

“Graphs” set the max number of raw traces than click OK button. [typical setting: up to 20 

traces while recording] 

5. Push Stop Button to finish the recording. 

6. You can open the recorded .bwr file in the „file location‟ folder. 

7. Proceed with instructions on “Replayer”. 

 

5.2. Load a file 

BW can load both raw data files (.brw) and result files (.bxr). The first type allows viewing the 

voltage vs. time traces for each electrode, while the second type allows also exploring the detected 

activity (spike events), providing raster plot visualizations and statistics such as the Mean Firing 
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Rate (MFR) and the Inter Spike Interval (ISI).  These statistics are available for each single channel 

or globally at network level. 

Select File->Open in the main menu and load one of your .bxr result files or a file from the 

BrainWaveDemoFiles folder (nb: if you load the .brw file, results are not available). On the left side 

the three control windows appear: Controls, Settings and Cluster Manager (see General commands 

and controls). On the right side a tab linked to the loaded file is shown. 

 

A set of sub-tabs for the loaded file are visible allowing the user to switch from raw data 

visualization to one of the available analysis results and vice versa. In the following paragraphs 

each tab is described in detail. 

5.2.1. Replayer tab 

This tab is made up of three sections: on the upper left corner a Camera View showing a 64 by 64 

false color map representation of the voltage values recorded for each channel; on the bottom-left 

corner a Commands window with information and buttons to control the replaying of the raw data; 

on the upper right corner a Replayer Controls window containing other controls used during 

replaying; on the bottom right side a large panel to show voltage waveforms of individual channels.  

Two possible color visualization modes (selectable by the Settings window) are available for the 

Camera View.  

 Variance: this mode is the visualization of the difference between the max and min voltage 

values within the moving time window. This window can be set using the Frame control in the 

Settings window 

 Potential: this second mode is the absolute voltage potential. The minimum and maximum 

values of the color scale bar correspond to the minimum and maximum voltage value in the 

voltage range track bar in the Controls window under Graphs Managing 



BrainWave manual V0.2 

 

 

7 

 

 

By moving the cursor over the color map or over the 64 by 64 grid shown in the Controls window, 

a tool tip showing the coordinate of the channel corresponding to cursor location will appear. A 

context menu is available by clicking the right mouse button on the color scale bar under the 

Camera View representation. By using this menu, the user can change the color scale to exponential 

or can change the colors used for representing voltage values.  

By selecting a channel on the color map or on the 64 by 64 grid shown in the Controls window, the 

voltage versus time plot of the corresponding channel appears in the right panel. To open more than 

one channel just drag an area or hold the Shift key during the selection. A context menu for short-cut 

selection/de-selection of channels is available by clicking the right button of the mouse. The red 

marker on the raw data trace represents the voltage value plotted in the color map when Image 

displayed is on Potential visualization mode. The two red lines at the right and left of the red 

marker delimit the moving/sliding window within which the variation visualization is calculated. 

 

The “Play” and “Stop” buttons in the Commands window allow starting and stopping of the 

streaming visualization. Under the Replayer Control window, the user can set the speed of 

streaming by moving the speed bar or jump from one point to another of the recording by scrolling 

the temporal bar (Data Stream Position bar).  
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When Replay is stopped the user can move forward or backward just by selecting the temporal bar 

and using the “left” or “right arrow” keys. In this configuration data are visualized by a small 

moving time window of the recorded signal (the user can adjust the time window size by changing 

the Raw Interval under the Settings window). To visualize bigger portions of the signals, the user 

has to switch from the Play Mode to the Full View visualization by clicking the corresponding 

button under the Commands window. In the “Full View” mode no playback is allowed and the 

plotted raw data time interval corresponds to the interval set in the temporal range track bar in the 

Controls window under Graph Managing. In this modality all sampled points are visualized 

allowing fine zooming that can be used for signal shape recognition, for example. By clicking the 

“Play Mode” button, the user can return to the streaming visualization. 

The voltage scale, the Camera View color map visualization and the time interval displayed in the 

raw data plots can be set in the Controls and Settings windows respectively. Close-up of the raw 

data traces can be easily done just by dragging a selection box around the interested area on the 

plot. A context menu for zooming operation is available by clicking the right button of the mouse. 

5.2.2. Spike Statistics tab 

This tab is a summary of the computed analysis in terms of firing rate. On the top left a color map 

represents the Mean Firing Rate (MFR), i.e. the number of spike/sec, calculated on the whole 

recording for each channel. On the right, a graph provides the distribution of the MFR ordering 

channels from the most spiking to the least spiking one. On the bottom left a table with the statistic 

for each channel showing the number of detected spikes, the MFR and the Inter Spike Interval (ISI) 

i.e. the mean latency between two consecutive spikes belonging to the same channel.  

The right panel is dedicated to the overall statistics. The “In-Range Channels” represents a set of 

channels whose firing rate is between a minimum and a maximum firing threshold selectable by the 

Settings window. In this way it is possible to eliminate noisy channels (i.e. channels with a high 

firing rate not biologically plausible) or the too few active ones. The overall statistics also provides 

statistics for the selected cluster (see Cluster Manager window). By changing the representation 

mode from “Mean Firing Rate” to “Inter-Spike Interval” in Settings window, the color map and 

graph commute representing ISI statistic. 
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5.2.3. Raster tab 

The raster tab allows visualizing the detected events for each channel vs. time. User can select the 

desired channels simply by clicking them on the channel layout map in Controls window (use the 

Shift key for multiple selections). In Settings window user can change the type of visualization. The 

available options for Plot type are: 

 “Cumulative Data”: all the selected channels are visualized in a unique graph 

 “Per-Channel Data”: each channel is plotted in a separate graph  

 “Per-Cluster Data”: a raster plot for each cluster is visualized (to create clusters see Cluster 

Manager window) 

By using drag-and-drop on the raster plot it is possible to zoom on a specific temporal window. The 

temporal range track bar in Controls window is automatically updated. By moving the cursor on the 

graphs a tool tip shows the coordinate of the channel pointed by the cursors. 

5.2.4. Firing Rate Analysis tab 

This tab allows visualizing the calculated firing rate (i.e. the number of detected events per user-

defined time bin) for each channel vs. time. User can select the desired channels simply by clicking 

them in the channel layout map in Controls window (use the Shift key for multiple selections). In 

Settings window user can change the type of visualization. The available options are: 

 “Cumulative Data”: all the selected channels are used to yield cumulative firing rate values 

visualized in a single graph 

 “Per-Channel Data”: each channel is plotted in a separate graph  

 “Per-Cluster Data”: a cumulative firing rate plot for each cluster is visualized (to create clusters 

see Cluster Manager window) 
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By drag and drop on the raster plot it is possible to zoom on a specific temporal window. The 

temporal range track bar in Controls window is automatically updated. By moving the cursor on the 

graphs a tool tip shows the coordinate of the channel pointed by the cursors. The firing rate is 

calculated by integrating the number of detected events in a certain temporal window, this interval 

can be changed in Settings window. 

5.2.5. ISI tab 

This tab allows visualizing the calculated Inter Spike Interval (ISI), i.e. the latency probability 

between a detected event and the following on the same channel. User can select the desired 

channels simply by clicking them in the channel layout map in Controls window (use the Shift key 

for multiple selections). In Settings window user can change the type of visualization. The available 

options are: 

 “Cumulative Data”: all the selected channels are used to calculate cumulative ISI values that are 

visualized in a single graph 

 “Per-Channel Data”: each channel is plotted in a separate graph  

 “Per-Cluster Data”: a cumulative ISI plot for each cluster is visualized (to create clusters see 

Cluster Manager window) 

By moving the cursor on the graphs a tool tip shows the coordinate of the channel pointed by the 

cursors. The ISI probability is reported in the distribution plot by integrating the number of latencies 

for a temporal bin that can be set in the Settings window. Moreover, the user can choose the 

maximum ISI value to be considered to plot the graph and the type of scale to use, either linear or 

semi-logarithmic. 

6. General commands and controls 
 

BrainWave™ provides a set of commands and controls “general purpose” that allow the user to 

change visualization settings or to manage analysis parameters specific to each tab. When a file is 

loaded (both .brw and .bxr), in the main window user can select graph arrangement and 

exclude/include scale visualization by using the visual menu on the top tool strip. When the 

Replayer tab is selected the “Show spike event” button allows visualizing the voltage raw traces 

superimposed with the detected events.  

 

In the following section the three main managing windows (selectable from the main menu in 

View->…) are discussed in details. 

6.1. Controls window 

It contains two main sections, the first regarding general information about the experiment 

(Experiment Info panel): the user can read the loaded file path, the duration and the sampling 
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frequency at which the recording has been acquired. The second is the Graphs Managing panel 

where the temporal and the voltage scale can be set by using the range track bars. Channels can be 

selected independently on the active result tab, by clicking on the 64 by 64 layout representation. 

Channels belonging to a cluster are colored with the cluster color itself (see Cluster Manager 

window). 

 

6.2. Settings window 

All the parameters concerning visualization, which are specific for a certain result tab (Spike 

Statistics, Raster, etc.), are collected in this window. When the Replayer tab is active it is possible 

to define the visualization time interval for the raw data plots, and the color visualization mode for 

the Camera View (see Replayer). In Spike Statistics tab the user can select the Mean Firing Rate or 

the Inter Spike Interval visualization and apply the low and high threshold values to set the range of 

active channels.  

By clicking the down arrow on the top right and selecting “New List from In-range Chs…” a 

cluster containing the channels, whose firing rate is in the range between Low and High Threshold, 

is created. Visualization settings specific for each analysis are available for Raster, Firing Rate 

Analysis and ISI tab. 
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6.3. Cluster Manager window 

This window contains a list of all the clusters created by the user. User can create clusters simply by 

selecting the desired channels and clicking the “Create new cluster” button. Hence, a “Create new 

Cluster” window appears; the user has to add a name, choose the identifying color and select the 

“add Selected Channels” option. When a cluster is created its statistics appear in the Overall 

Statistic panel in the Spike Statistic tab. A cluster can be deleted by selecting it and clicking the 

“Canc” key.  

 

To select channels that belong to the clusters only, user has to click on the “limit selection” button 

in the bottom right of the window. This allows visualizing only the channels belonging to the 

checked clusters in the list. 
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7. Spike detection analysis 

 

To perform spike detection analysis by varying the parameters, click on analysis in the main menu 

and select the “peak detection” option. A Peak Detection window appears where user can set the 

following three main parameters: 

 “Standard deviation factor”: the number of times the signal has to overcome the StdDev of the 

basal noise to be considered as an event 

 “Peak Lifetime Period”: the maximum duration of an event expressed in milliseconds 

 “Refractory Period”: the minimum distance between two detected events expressed in 

milliseconds 

Then user can define whether to assign the timestamp of the detected event either to the positive or 

to the negative peak or the higher of both. The user can check the option for an accurate detection, 

by which the StdDev of the noise is constantly updated while the raw data is scanned for spike 

events. 

The analysis can be performed on the entire array or can be restricted to a subset of channels by 

clicking on the “Limit to a Group of channels” checkbox and selecting the area of interest by 

multiple click or drag and drop (a selection via cluster definition can also be done). 

7.1. Automate batch 

BrainWave™ provides a batch to automatically analyze multiple files. This feature allows the 

unsupervised analysis of large dataset; files are computed in parallel taking advantage of PC multi-

core architecture. To start a batch, click on File->Automate->Batch in the main menu. The Prepare 

For Batch window appears, the user has to select the folder containing the .brw files to be analyzed 

by double clicking the “Search in Folder” box. A list of the files appears, click on “Accept” button. 

The Batch window appears where the user can set the parameters for detecting events as described 

in the previous paragraph. Click the “OK” button to start analysis.  
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8. Exporting in MATLAB
®
 

 

Both raw data and result files can be exported in different formats. This allows the compatibility 

with other analysis software, leaving the user free to develop “ad hoc” algorithms in other 

languages. In this version, files can only be exported in .mat files (MATLAB® see 

www.mathworks.com).   

8.1. Raw data  

Load the file that has to be exported in MATLAB. Click on File->Export->RawData. The Export  

Raw Data window appears, by which the user can select the name of the file(s) and the folder where 

to store it. The export can be performed on the entire channel array or can be restricted to a subset 

of channels by selecting the “Export data only for a subset of channels” and selecting the area of 

interest by multiple click or drag and drop (a selection via cluster definition can also be done). Also 

the exporting time interval can be set by clicking on “Time Interval(s)…” button and choosing one 

or more temporal windows. 

Channels can be exported in separate files or grouped into a single file by selecting the “Group 

multi channel data in a single file” checkbox. Raw data are saved in an array for each channel of 

quantized levels or MilliVolt values depending on the “Coding Type” selected option. Each element 

of the array represents a sample (sampling frequency 7702Hz). 

http://www.mathworks.com/
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8.2. Spike trains 

Load the file to be exported in MATLAB. Click on File->Export->Results in the main menu. The 

Export  Results window appears, by which the user can select the name of the file(s) and the folder 

where store it in the Destination section. The export can be performed on the entire channels array 

or can be restricted to a subset of channels by selecting the “Export data only for a subset of 

channels” and selecting the area of interest by multiple click or drag and drop (a selection via 

cluster definition can also be done). Also the export time interval can be set by clicking on “Time 

Interval(s)…” button and choosing one or more temporal windows. The user has to select the 

“Spike Time Stamps” option in the Available Results section and click on “Add >>” button. The 

“Spike Time Stamps” option moves to the Export Results section, by clicking on it, the user can 

select whether to export the results to a sparse matrix or to a full matrix by setting the “Format” 

option in the Selected Result Options section. 

 

The generated .mat files are organized in rows, one for each channel. Each row is a full or sparse 

array (depending on the selected option) where every value represents a sample (sampling 

frequency 7702Hz). The array values are zero where no events are detected, while when an event is 

detected the sample value is the peak amplitude expressed in MilliVolts or 1 (if “Export binary 

arrays” option is selected).  
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9. Tips and tricks 

 

Simultaneous recording of 4096 channels at about 8 kHz is an important technological progress in 

the “MEA world” but introduces some issues in terms of analysis regarding the amount of collected 

data. For example, 5 minutes raw data recording is equivalent to a file of about 18 Gigabytes. 

Therefore analysis and results visualization have been designed in order to help users in data mining 

and fast extraction of the searched results. Here some tips and tricks are described to help the user 

in his work. 

9.1. Spike statistics tab as your starting point 

We suggest having a global idea of your analysis by looking at the MFR channel distribution on 

your experiment in the Spike Statistics tab. This immediately gives an idea of how activity is 

distributed, and by setting low and high threshold visualization, it is possible to create a cluster 

from the Settings window only containing the channels of interest. Then, from the main cluster of 

valid channels it is possible to create a series of sub-clusters that can be visualized separately in the 

Raster tab. In any case keep the selection of channels always limited to the checked cluster (see 

cluster manager paragraph) to avoid the selection of undesired channels. 

 

9.2. Organizing activity in cluster 

The segregation of channels into clusters can be very useful especially when the biological model 

presents spatially well defined regions of cell population. For example this is the case of slices 

where it is easy to recognize precise areas of activity like the CA1, CA3 and dentate gyrus in the 

hippocampus. In this condition the overall statistics can be really insignificant due to the highly 

variable behaviors of the brain regions. Dividing into clusters and looking at the statistics for each 

of them can be an approach to better understand electrical activity dynamics among regions.   
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9.3. Fast recognition of activity 

In Replayer tab the global visualization of the activity can be very useful in finding neuronal 

signaling. We suggest always working in variance mode (see Settings window) because it computes 

a sort of integration of the signal within a moving temporal window.  

 

 

In order to better highlight the activity, we suggest setting the scale color bar in the exponential 

mode and setting the number of integration frames to at least at 300-350 (about 400 msec). In this 

way the software provides a rough visualization that can help in finding the desired activity. Then 

after having temporally localized it and in order to better appreciate the spatial propagation of the 

signal, decrease the number of integration frames to 15 (about 2 msec), or move to potential mode 

color map visualization.  

9.4. From raster to raw data visualization 

Looking for activity by using the raw data replayer is not always trivial in fast localization of 

signaling both at temporal scale and spatial distribution. We suggest visualizing the raster plot of 

the main active channels. Then after localization of the desired activity, zoom on it by drag and 

drop directly on the raster. In this way the temporal range track bar in Controls window is set on the 

temporal close-up selected in the raster plot. Moving to the Replayer tab, the playback is limited to 

the selected temporal interval to avoid wasting time in finding the right instance of activity. 

 

10. Contact Details 

Technical Support: Plexon Inc 
   6500 Greenville Ave., Suite 730 
   Dallas TX 75206 
   USA 
   support@plexon.com 
   Tel: +1-214-369-4957 

mailto:support@plexon.com

